South Africa: Card transactions failing
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted May 09, 2023 - 21:12 CET
Monitoring
Card transactions are processing normally again. We will continue to monitor.
Posted May 09, 2023 - 20:44 CET
Identified
The issue has been escalated to our 3rd party partners. They are currently working on a fix.
Posted May 09, 2023 - 20:36 CET
Investigating
We are seeing an increase in card transactions failing. We are busy investigating the issue.
Posted May 09, 2023 - 20:22 CET
This incident affected: Transactions (Cards).