Paystack - Nigeria: Outage on Paystack Direct Debit – Incident details

All systems operational

Nigeria: Outage on Paystack Direct Debit

Resolved
Degraded performance
Started 3 months agoLasted 27 minutes

Affected

Transactions

Operational from 9:25 AM to 9:25 AM, Degraded performance from 9:25 AM to 9:52 AM

NIGERIA

Operational from 9:25 AM to 9:25 AM, Degraded performance from 9:25 AM to 9:52 AM

Direct Debit

Operational from 9:25 AM to 9:25 AM, Degraded performance from 9:25 AM to 9:52 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    Direct Debit is currently unavailable across all banks. Debits on already‑linked accounts are failing. Our team is investigating with the service provider and will provide updates shortly.