Paystack - Outage on NIBSS Direct Debit – Incident details

All systems operational

Outage on NIBSS Direct Debit

Resolved
Degraded performance
Started 2 months agoLasted 3 days

Affected

Transactions

Operational from 3:15 PM to 3:15 PM, Degraded performance from 3:15 PM to 10:03 AM

NIGERIA

Operational from 3:15 PM to 3:15 PM, Degraded performance from 3:15 PM to 10:03 AM

Direct Debit

Operational from 3:15 PM to 3:15 PM, Degraded performance from 3:15 PM to 10:03 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    A fix has been implemented and we are monitoring the results.

  • Investigating
    Investigating

    Direct Debit is currently unavailable across all banks. This is a result of a downtime with the central switch. What is Affected? - Attempts to charge already-linked accounts may fail. - Attempts to link new bank accounts may also fail. We are in communication with the service provider and will provide updates as soon as possible.