South Africa: 3D Secure Transactions

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Apr 16, 2023 - 05:17 CET

Monitoring

Success rates have stabilised. We will continue to monitor.
Posted Apr 16, 2023 - 02:29 CET

Identified

We are seeing an increase in failure rates for 3D Secure transactions due to unplanned maintenance being performed by Bankserv. We will continue to monitor.
Posted Apr 15, 2023 - 23:58 CET
This incident affected: Transactions (Cards, QR).