Timeouts on our endpoints
Incident Report for Paystack
Resolved
This incident has been resolved. This incident was caused by an issue a service provider of ours, Cloudflare, was having on its own network. You can find their incident report at https://www.cloudflarestatus.com/incidents/46z55mdhg0t5.

We are implementing changes to ensure similar issues does not impact on our services at this scale.
Posted 4 months ago. Jun 24, 2019 - 15:09 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Jun 24, 2019 - 13:51 CET
Update
Payment Pages are now fully operational. Work is ongoing to bring back other components online
Posted 4 months ago. Jun 24, 2019 - 13:37 CET
Identified
An issue has been identified with our internal DNS system and we are making changes that should resolve this shortly.
Posted 4 months ago. Jun 24, 2019 - 13:27 CET
Investigating
We are currently experiencing high API response times on our endpoints. Our infrastructure is currently looking into the issue
Posted 4 months ago. Jun 24, 2019 - 12:45 CET
This incident affected: API and Transfers.