Downtime on transactions in South Africa
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Jul 13, 2022 - 20:35 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 13, 2022 - 20:11 CET
Update
We are continuing to investigate this issue.
Posted Jul 13, 2022 - 19:35 CET
Investigating
We are currently investigating failures on our payment channels for South African merchants.
Posted Jul 13, 2022 - 19:34 CET
This incident affected: Transactions (Cards).