Paystack - Paystack Dashboard – Incident details

Dashboard experiencing degraded performance

Paystack Dashboard

Investigating
Degraded performance
Started 1 day ago

Affected

Merchant Tools

Degraded performance from 8:00 AM to 12:00 AM

Dashboard

Degraded performance from 8:00 AM to 12:00 AM

Updates
  • Update
    Update

    We have narrowed down the cause of the login issues and confirmed that this disruption is affecting a small number of merchants.

    Our team is currently finalizing a fix. We will provide a further update as soon as service is fully restored.

  • Investigating
    Investigating

    Some merchants are currently experiencing difficulties logging in to their Dashboard. We are investigating the issue and working on a fix. We will share further updates here shortly.