Paystack - Nigeria: Paystack Titan Downtime – Incident details

Direct Debit experiencing partial outage

Nigeria: Paystack Titan Downtime

Resolved
Major outage
Started about 5 hours agoLasted 42 minutes

Affected

Transactions

Degraded performance from 3:49 PM to 4:31 PM

NIGERIA

Degraded performance from 3:49 PM to 4:31 PM

Bank Transfer

Degraded performance from 3:49 PM to 4:31 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating

    We’re currently experiencing an issue affecting Pay with Transfer on Paystack Checkout, and some customers may be unable to complete payments using that option.

    Kindly have your customers complete payments via alternative methods such as Bank, Card, or Zap, etc

    We’re investigating this urgently and apologise for the inconvenience.