Ghana: Downtime with Telecel service

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 16:42 CET

Investigating

Our partner, Telecel, is currently having a downtime on their platform, which is affecting mobile money transactions. As a result, most Telecel transactions are failing.

We're currently liaising with them to fix the issues and restore the service.
Posted Mar 14, 2025 - 10:11 CET
This incident affected: Transactions (Mobile Money).