We are pleased to inform you that the Paystack Direct Debit service is improving. The issue with our partner has been resolved and we are monitoring the performance closely. Thank you for your patience and understanding during this period. If you encounter any further issues, please do not hesitate to reach out
Posted Sep 12, 2024 - 11:03 CET
Update
We are continuing to investigate this issue.
Posted Sep 11, 2024 - 15:28 CET
Investigating
We have identified an outage with NIBSS affecting the Paystack Direct Debit and Account linking services. We are actively working with the NIBSS team to resolve the issue. We apologize for any inconvenience this may cause and will provide an update as soon as the service is restored.
Posted Sep 11, 2024 - 10:02 CET
This incident affected: Transactions (Direct Debit).