Paystack - Ghana: MTN Payments – Service Disruption – Incident details

Experiencing partially degraded performance

Ghana: MTN Payments – Service Disruption

Resolved
Major outage
Started 2 days agoLasted about 1 hour

Affected

Transactions

Major outage from 6:11 PM to 7:14 PM

GHANA

Major outage from 6:11 PM to 7:14 PM

Mobile Money

Major outage from 6:11 PM to 7:14 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Redundant measures have been implemented and we are observing improved success rates for payments via MTN. Our team continues to monitor performance closely to ensure stability.

  • Investigating
    Investigating

    We are aware of issues affecting payment completion via MTN. Our team is actively investigating the cause and has implemented redundant measures to restore normal service. Updates will be shared here as soon as they are available.