Paystack - Direct Debit Account Approval Downtime – Incident details

Direct Debit experiencing degraded performance

Direct Debit Account Approval Downtime

Monitoring
Major outage
Started 1 day ago

Affected

Transactions

Operational from 12:30 PM to 3:55 PM, Partial outage from 3:55 PM to 4:41 PM, Degraded performance from 4:41 PM to 12:00 AM

NIGERIA

Operational from 12:30 PM to 3:55 PM, Partial outage from 3:55 PM to 4:41 PM, Degraded performance from 4:41 PM to 12:00 AM

Direct Debit

Operational from 12:30 PM to 3:55 PM, Partial outage from 3:55 PM to 4:41 PM, Degraded performance from 4:41 PM to 12:00 AM

Updates
  • Monitoring
    Monitoring

    The central switch has implemented a fix for the Direct Debit approval service. Customers should now be able to link their bank accounts successfully. We are monitoring performance to ensure continued stability.

  • Identified
    Identified

    We have identified the root reason why customers are not able to approve their mandates successfully and are working with the central switch on a resolution.

  • Investigating
    Investigating
    We are currently experiencing an issue affecting our Direct Debit bank approval service. As a result, customers will be unable to link their bank accounts for Direct Debit. We are working with the central switch to fix this as soon as possible.