Paystack - Nigeria: Paystack Direct Debit Downtime – Incident details

All systems operational

Nigeria: Paystack Direct Debit Downtime

Resolved
Major outage
Started about 15 hours agoLasted about 9 hours

Affected

Transactions

Major outage from 10:11 AM to 7:38 PM

NIGERIA

Major outage from 10:11 AM to 7:38 PM

Direct Debit

Major outage from 10:11 AM to 7:38 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    The Central Switch is experiencing an issue causing Direct Debit account linking and payment attempts to fail. We are in communication with them to restore service as soon as possible.