Paystack - Nigeria: Delay in Completing Transfers and Direct Debit Transactions – Incident details

Direct Debit experiencing degraded performance

Nigeria: Delay in Completing Transfers and Direct Debit Transactions

Resolved
Partial outage 30 %
Started 3 days agoLasted about 3 hours

Affected

Transactions

Degraded performance from 11:53 AM to 2:25 PM

NIGERIA

Degraded performance from 11:53 AM to 2:25 PM

Bank Transfer

Degraded performance from 11:53 AM to 2:25 PM

Direct Debit

Degraded performance from 11:53 AM to 2:25 PM

Transfers

Partial outage from 11:53 AM to 2:25 PM, Operational from 11:53 AM to 2:25 PM

NIGERIA

Partial outage from 11:53 AM to 2:25 PM, Operational from 11:53 AM to 2:25 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We are currently experiencing a downtime with the central switch in Nigeria. As a result, you may notice:

    1. Delays in transfers to Paystack Titan and Wema-managed accounts via both Pay with Transfer (PwT) and Dedicated Virtual Accounts (DVA).

    2. Delays in processing outward transfers to all bank accounts.

    3. Increased failures when linking bank accounts for Direct Debit

    4. Increased failures when trying to make Direct Debit payments

    Our team is actively working with partners to resolve this issue and will provide updates as soon as service is fully restored.