Nigeria: Delayed Transfers to Opay Accounts

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Mar 30, 2025 - 17:09 CET

Monitoring

Opay appears to have recovered, but we'll continue to monitor the situation and share updates as they become available.
Posted Mar 30, 2025 - 09:53 CET

Investigating

Opay is currently experiencing a downtime, hence you might experience a delay in Outbound transfers to Opay accounts.

We're currently in contact with them to resolve this issue as quickly as possible and we'll provide an update as soon as it has been resolved.
Posted Mar 30, 2025 - 09:05 CET
This incident affected: Transactions (Pay with Transfer/EFT) and Transfers.