South Africa: 3D Secure
Incident Report for Paystack
Resolved
3D Secure success rates have stabilised.
Posted Mar 02, 2023 - 16:16 CET
Investigating
We are seeing an increase in errors for 3D Secure transactions. The issue has been escalated to Bankserv.
Posted Mar 02, 2023 - 15:19 CET
This incident affected: Transactions (Cards, QR).