Nigeria: Downtime on Zenith Bank card transactions

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Mar 09, 2025 - 17:44 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2025 - 15:42 CET

Investigating

We are seeing an increase in failure rates on cards issued by Zenith Bank. This is due to a downtime at the bank.

We have notified the Zenith bank team and are in close contact with them to resolve this issue as quickly as possible.
Posted Mar 09, 2025 - 09:51 CET
This incident affected: Transactions (Cards).