South Africa: Increased rate of 3DS failures
Incident Report for Paystack
Resolved
Success rates have been stable since 18:05 SAST
Posted Dec 19, 2024 - 17:29 CET
Investigating
We are seeing an increased rate of failures for 3D secure transactions. The issue has been escalated to out 3rd party partners.
Posted Dec 19, 2024 - 16:13 CET
This incident affected: Transactions (Cards).