Downtime on Pay with Transfer channel in Nigeria
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Nov 12, 2023 - 20:07 CET
Investigating
Due to a technical disruption, there might be a delay in confirmation of deposits for transactions into Virtual Accounts

We're working to resolve this issue as quickly as possible and will provide an update as soon as it has been resolved.
Posted Nov 12, 2023 - 16:53 CET
This incident affected: Transactions (Pay with Transfer/EFT).