Downtime on Paystack Transfers and the Pay with Transfer channel in Nigeria
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Nov 08, 2023 - 22:09 CET
Investigating
Due to a technical disruption with a 3rd party, we're observing delays in processing transfers in Nigeria. We are working with our partners to resolve this issue as quickly as possible and will provide an update as soon as the issue has been resolved.
Posted Nov 08, 2023 - 19:37 CET
This incident affected: Transfers.