South Africa: 3D Secure transactions failing
Incident Report for Paystack
Resolved
3D Secure success rates have returned to normal.
Posted May 05, 2023 - 00:54 CET
Identified
The issue has been escalated to Bankserv. They are looking into it.
Posted May 04, 2023 - 23:39 CET
Investigating
We are seeing an increase in the failure rate for 3D Secure transaction in South Africa. We are busy investigating the issue.
Posted May 04, 2023 - 23:30 CET
This incident affected: Transactions (Cards, QR).