South Africa: Capitec-issued card failing 3DS
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 18:27 CET
Monitoring
Capitec-issued cards have been processing normally since 18:45 SAST. We will continue to monitor.
Posted Mar 22, 2024 - 18:00 CET
Identified
3DS transactions are currently failing for Capitec-issued cards. The issue has been escalated to our 3rd-party partners.
Posted Mar 22, 2024 - 17:41 CET
This incident affected: Transactions (Cards).