South Africa: Mastercard 3DS failures
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Aug 18, 2023 - 09:16 CET
Monitoring
Transactions have been processing normally again since 9:53 SAST. We will continue to monitor
Posted Aug 18, 2023 - 09:05 CET
Identified
Only Capitec-issued cards are affected. The issue has been escalated.
Posted Aug 18, 2023 - 08:49 CET
Investigating
We are seeing an increased failure rate for Mastercard 3DS transactions. The issue has been escalated to our 3rd-party partners.
Posted Aug 18, 2023 - 07:53 CET
This incident affected: Transactions (Cards).