South Africa: EFT Ozow payments failing
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted May 12, 2023 - 16:36 CET
Monitoring
Ozow transactions are processing normally again. We will continue to monitor.
Posted May 12, 2023 - 16:13 CET
Identified
EFT payments via Ozow are currently failing. The issue has been escalated to Ozow and they are working on a fix.
Posted May 12, 2023 - 15:53 CET
This incident affected: Transactions (Pay with Transfer/EFT).