South Africa: Degraded performance for Nedbank-issued cards

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Feb 07, 2025 - 17:02 CET

Investigating

We are seeing an increased rate of failure for transactions using Nedbank-issued cards. The issue has been escalated to our 3rd-party partners.
Posted Feb 07, 2025 - 15:31 CET
This incident affected: Transactions (Cards).