Global: Error initiating transfers to bank accounts
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted May 03, 2024 - 20:23 CET
Investigating
Our Transfers service is currently down. We are investigating and will provide an update as this progresses.
Posted May 03, 2024 - 20:02 CET
This incident affected: Transfers.