Delay in completing transfers into Titan Trust Bank
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Sep 08, 2023 - 10:07 CET
Investigating
Titan Trust Bank is currently experiencing a downtime and this will affect confirmation of deposits for top ups.

We're working with them to resolve this issue as quickly as possible and will provide an update as soon as it has been resolved.
Posted Sep 08, 2023 - 09:13 CET
This incident affected: Transfers.