South Africa: Card transactions failing
Incident Report for Paystack
Resolved
Transactions have been processing normally since 14:18
Posted Sep 27, 2023 - 13:25 CET
Investigating
Card transaction are currently failing. The issue has been escalated to our 3rd-party partners.
Posted Sep 27, 2023 - 12:25 CET
This incident affected: Transactions (Cards).