South Africa: EFT Ozow payments failing

Incident Report for Paystack

Resolved

The fix has fully rolled out and transactions are processing normally again.
Posted Apr 01, 2025 - 11:17 CET

Identified

EFT Ozow payments have started failing again. We have identified a possible cause and we are working on getting a fix out.
Posted Apr 01, 2025 - 10:35 CET
This incident affected: Transactions (Pay with Transfer/EFT).