Paystack - Nigeria: Paystack Direct Debit – Incident details

All systems operational

Nigeria: Paystack Direct Debit

Resolved
Major outage
Started 18 days agoLasted 4 days

Affected

Transactions

Major outage from 10:03 AM to 9:28 AM, Partial outage from 9:28 AM to 9:21 AM

NIGERIA

Major outage from 10:03 AM to 9:28 AM, Partial outage from 9:28 AM to 9:21 AM

Direct Debit

Major outage from 10:03 AM to 9:28 AM, Partial outage from 9:28 AM to 9:21 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified

    We are continuing to address the disruption affecting Direct Debit services.

    Existing payment authorizations remain functional, however, users will encounter errors when attempting to link new accounts or establish new mandates. Our team is focused on restoring the registration service for new mandates as a priority.

  • Investigating
    Investigating

    We are currently investigating an issue that is preventing users from linking new Direct Debit accounts and processing payment attempts.