Paystack - Nigeria: Increased failures on Point of Sale (POS) Transactions – Incident details

Experiencing partially degraded performance

Nigeria: Increased failures on Point of Sale (POS) Transactions

Resolved
Major outage
Started about 15 hours agoLasted about 5 hours
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are currently investigating an issue causing elevated error rates and timeouts for some Point of Sale (POS) transactions. This is as a result of a downtime with the central switch in Nigeria.

    What does this mean for you?
    You may experience intermittent transaction failures or delayed responses while making payments on physical POS terminals.

    We are actively working with our partner to resolve this issue and will share updates as soon as possible.

    We apologize for any inconvenience this may cause.