Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 06, 2025 - 21:00 CET
Scheduled
Our acquiring partner, Nedbank, will be conducting scheduled network maintenance on Sunday, 6 April 2025, starting at 22:00 and concluding at 03:00 on Monday, 7 April 2025 (SAST).
What does this mean for you? Redundant connectivity is in place and there is no downtime expected, however, you may experience minor disruptions on the network during the maintenance window.
Should you have any questions or concerns, please reach out to us on support@paystack.com
Posted Apr 04, 2025 - 15:06 CET
This scheduled maintenance affected: Transactions (Cards, QR).