Ghana: Partner downtime impacting mobile money transactions

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Feb 20, 2025 - 06:54 CET

Investigating

Our partner, MTN, is currently having a downtime on their platform, which is affecting mobile money transactions at the moment. As a result, most MTN transactions are failing.

We're currently liaising with them to fix the issues and restore the service. Please bear with us.
Posted Feb 19, 2025 - 08:16 CET
This incident affected: Transactions (Mobile Money).