South Africa: Increased 3DS failure rate

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Nov 16, 2023 - 23:31 CET

Monitoring

Capitec transactions are processing normally again. We will continue to monitor.
Posted Nov 16, 2023 - 23:17 CET

Identified

We are experiencing an increased rate of failures during 3DS transactions for Mastercards issued by Capitec. The issue has been escalated to our 3rd party partners.
Posted Nov 16, 2023 - 21:59 CET
This incident affected: Transactions (Cards).