Paystack Ghana: Major Downtime on AirtelTigo Ghana Mobile Money Transactions & Transfers
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Dec 11, 2023 - 19:53 CET
Investigating
There is currently an issue with AirtelTigo Ghana affecting both Mobile Money transactions & transfers. The AirtelTigo Ghana team is working to have this issue fixed and will update us on their progress
Posted Dec 11, 2023 - 12:14 CET
This incident affected: Transactions (Mobile Money) and Transfers.