Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 01, 2023 - 23:15 CET
Scheduled
We received a notification from Ozow that they’ll undergo emergency maintenance for one hour on Thursday, 2 November 2023, from 00:30 - 01:30 (SAST).
What does this mean for you? During this period, you won't be able to accept payments from customers through Ozow EFT, and you won't be able to add funds to your transfer balance. Rest assured, you’ll still be able to accept payments as usual via our other payment channels, including direct card payments, SnapScan, and Scan to Pay.
To minimize the impact on ongoing transactions, the EFT payment option will be temporarily hidden from your customers between 00:15 and 01:45 (SAST).
Posted Nov 01, 2023 - 16:40 CET
This scheduled maintenance affected: Transactions (Pay with Transfer/EFT).