Nigeria: Outage on Paystack Direct Debit

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted May 06, 2025 - 14:34 CET

Investigating

Direct Debit is currently down across all banks.

As a result, attempts to debit already-linked accounts are failing.

We are working closely with the service provider to investigate the issue and will share updates soon.
Posted May 03, 2025 - 09:13 CET
This incident affected: Transactions (Direct Debit).