South Africa: Temporary Disruption – SnapScan and Scan to Pay Services

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted May 08, 2025 - 11:55 CET

Monitoring

The service has been restored. We will continue to monitor.
Posted May 08, 2025 - 11:22 CET

Identified

Our partner is experiencing networking issues. Their technical team is actively working to resolve the issue as quickly as possible.
Posted May 08, 2025 - 09:49 CET

Investigating

Paystack South Africa is currently experiencing technical issues resulting in timeouts on our SnapScan and Scan to Pay payment channels. The matter has been escalated to our service providers, who are actively working to resolve the issue.

To ensure a smoother checkout experience and avoid any inconvenience, we have temporarily disabled these payment options. We will reinstate them as soon as normal service is restored.
Posted May 08, 2025 - 09:14 CET
This incident affected: Transactions (QR).