Downtime on the BVN Verification Service
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Apr 02, 2021 - 10:24 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 02, 2021 - 10:10 CET
Update
We are continuing to work on a fix for this issue.
Posted Apr 01, 2021 - 13:15 CET
Identified
We're experiencing an issue where Bank Verification Numbers are not being resolved or verified successfully by our service. Our processing partners are aware of this issue and are urgently working on a fix.
Posted Apr 01, 2021 - 10:49 CET
This incident affected: BVN Resolve Service.