Nigeria: Delayed Paystack Titan inward transfers

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Apr 05, 2025 - 16:37 CET

Investigating

We're currently experiencing delays with bank transfers to Paystack Titan accounts.

Our team is actively investigating the issue and working to resolve it as quickly as possible.

We'll share an update once it's been fully resolved.
Posted Apr 03, 2025 - 14:15 CET
This incident affected: Transactions (Pay with Transfer/EFT) and Transfers.