Nigeria: Downtime on Zenith Bank and Union Bank Direct Debit Transactions

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted May 13, 2025 - 10:03 CET

Monitoring

We're seeing improved stability with Direct Debit on Zenith Bank, while Union Bank is still being monitored. We'll share further updates as more information becomes available.
Posted May 09, 2025 - 12:50 CET

Investigating

We're currently experiencing downtimes from Zenith Bank and Union Bank, affecting Direct Debit.

As a result, you may encounter errors when attempting to debit accounts from either bank.

What does this mean for you?
- Attempts to charge bank accounts issued by Zenith Bank and Union Bank via Direct Debit may fail.
- Direct Debit via other banks remain unaffected.
- Cards issued by both Zenith bank and Union bank are also unaffected

We're actively monitoring the situation and will provide updates as we receive more information from our banking partners.
Posted May 08, 2025 - 12:45 CET
This incident affected: Transactions (Direct Debit).