Paystack Dashboard & Checkout Downtime

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Feb 18, 2021 - 13:45 CET

Update

We are continuing to investigate this issue.
Posted Feb 18, 2021 - 13:44 CET

Investigating

We're experiencing an outage affecting the Dashboard, Checkout & Payslack. We're currently working on a fix and will update soon.
Posted Feb 18, 2021 - 13:15 CET
This incident affected: Dashboard.