Nigeria: Guaranty Trust Bank(GTBank) downtime

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 07:15 CET

Investigating

We are seeing an increase in failure rates on transfers to and on Cards issued by Guaranty Trust Bank. This is due to a downtime on the Bank's end.

We have notified the GTBank team and are in close contact with them to resolve this issue as quickly as possible, we will provide an update as soon as it has been resolved.
Posted Mar 31, 2025 - 16:11 CET
This incident affected: Transactions (Cards, Pay with Transfer/EFT) and Transfers.