Nigeria: Downtime on 737 USSD transactions

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 16:29 CET

Investigating

We are currently investigating an issue affecting payments made via our 737 USSD payment channel, and are working diligently with our partners to resolve the issue.

Customers are advised to use alternate payment channels.

Updates will be provided as we progress. Thank you for your understanding and patience.
Posted Aug 11, 2025 - 11:02 CET
This incident affected: Transactions (USSD).