South Africa: Increased failure rate for 3DS transactions
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Oct 19, 2024 - 18:13 CET
Monitoring
Success rates have been stable since 17:45 SAST. We will continue to monitor.
Posted Oct 19, 2024 - 17:41 CET
Investigating
We are seeing an increased rate of failure for 3D Secure transaction with Mastercard. We have escalated it to our 3rd-party partners.
Posted Oct 19, 2024 - 16:44 CET
This incident affected: Transactions (Cards, QR).