Kenya: Downtime on Safaricom M-PESA transactions
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Oct 14, 2023 - 13:18 CET
Monitoring
We’ve identified improvement in transaction processing. We continue to monitor the service until it has stabilized.
Posted Oct 14, 2023 - 12:18 CET
Investigating
There is currently an issue affecting M-PESA transactions. The M-PESA team is working to have this issue fixed and will update us on their progress.
Posted Oct 14, 2023 - 11:52 CET
This incident affected: Transactions (Mobile Money).