Nigeria: Delay in completing transfers to Stanbic IBTC Bank
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Sep 15, 2023 - 09:43 CET
Investigating
Transfers to Stanbic IBTC accounts in might experience a slight delay due to a downtime from the bank. We're working with them to resolve this issue as quickly as possible and will provide an update as soon as it has been resolved.
Posted Sep 14, 2023 - 21:00 CET
This incident affected: Transfers.