Nigeria: Downtime on Zenith Bank transactions

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Jul 20, 2025 - 09:57 CET

Investigating

We're currently experiencing downtimes from Zenith Bank affecting Direct Debit and recurring card transactions.

As a result, you may encounter errors when attempting to debit accounts from Zenith bank.

What does this mean for you?
- Attempts to charge bank accounts issued by Zenith Bank via Direct Debit may fail.
- Direct Debit via other banks remain unaffected.
- Cards issued by Zenith bank may experience failure for recurring transactions.

We're actively monitoring the situation and will provide updates as we receive more information from our banking partners.
Posted Jul 20, 2025 - 09:05 CET
This incident affected: Transactions (Cards, Direct Debit).