South Africa: Problem loading dashboard
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Aug 07, 2023 - 18:42 CET
Monitoring
Cloudflare has implemented a fix and is monitoring the change.
Posted Aug 07, 2023 - 16:58 CET
Identified
We have received reports that some of our merchants are experiencing issues when trying to load the Paystack dashboard. This is due to a Cloudflare issue affecting network performance in the region. They are working on a fix. You can follow the incident here: https://www.cloudflarestatus.com/incidents/g58yh97tkypx
Posted Aug 07, 2023 - 16:26 CET
This incident affected: Dashboard.