Ghana: MTN system downtime

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted May 07, 2025 - 13:53 CET

Identified

Our partner, MTN, is currently experiencing downtime on their platform, which is affecting mobile money transactions. As a result, most MTN transactions are failing. We're currently liaising with them to fix the issues and restore the service. Please bear with us.
Posted May 07, 2025 - 11:03 CET
This incident affected: Transactions (Mobile Money).